Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
ProgGPPCNexus_Cyclone_Max Programmer with version 6.22.00.00=> issue with Freescale_MPC5744P_Cflash_Dflash_cut2.pcp
Frédéric G. May 10, 2017 at 10:48 AM (10:48 hours)
Staff: Takao Y.

  • Hello,

    I'm using the cyclone max for production so i need to create an image and load it in my cyclone max for a MPC5744
    Until now, i could use the version 5.60.00 to program manually (with the ProgGPPCNexus_Cyclone_Max Programmer) and i could use the Cyclone Image Utility.

    But now i need program a new software in my product, but with a new pcp file (whose can write in C flash and D flash).
    With the version 5.60.00 i can program my product (but i have a warning about a new version required for this new pcp file "Freescale_MPC5744P_Cflash_Dflash_cut2.pcp")however i can program my product only manually with ProgGPPCNexus_Cyclone_Max Programmer.

    If i use the Cyclone Image Utility i have an error, and i can't create an image....

    I try your new version 6.22.00.00 and with this version i don't have the warning but i have a error during programming (with ProgGPPCNexus_Cyclone_Max Programmer)

    I can create a image with Cyclone Image Utility and i can load this image in my cyclone max but when i execute my image i have an error during programming (On the cyclone max i have the code error $3003)

    Did you even see this issue?
    Best regards




    Comments

  • Greetings,

    What firmware version do you have on your cyclone max? Are you using the algorithm that came with the software, or did you download the latest algorithms from our website?

    The reason why I ask this is because I made changes to the algorithm and firmware to be twice as fast in programming. But you must be using the latest software and firmware if you wish to use standalone.

    I just tested the algorithm again on my cyclone max and had no issues. Try also lowering the debug shift frequency and adding 200ms reset delay. It may not be the algorithm but something else that changed with the new software version.


    Takao Yamada

  • Thank you for your answer
    I use the algorithme that came with the software.
    The firmware version on my cyclone max is V7.94-6.2

    I try with a debug shift frequency at 3.846Mhz and it's the same thing

  • Greetings,

    Please go to Support page -> Support requests and please open a ticket. Describe your problem and post the binary file you are using and the algorithm you have selected. I will attempt to replicate the problem on my end and let you know if I see the same issue.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement