Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone MAX unable to flash SAP image, but DSC Programmer succeeds (MC56F84451)
Adam S. May 12, 2016 at 01:23 PM (13:23 hours)
Staff: Takao Y.

  • Any images created for an MC56F84451 micro using the Image Creation Utility result in an error 0x000007. However, trying to program using the same ELF image and the same programming steps manually using the DSC Programmer is successful. Any idea why this may be?




    Comments

  • Greetings,

    You may want to check the debug shift frequency. Try matching the exact settings you used in PROG DSC with the image creation utility and it should work just as well.

    Also make sure to always use the latest firmware and software from us when you run into issues like this:

    http://www.pemicro.com/downloads/download_file.cfm?download_id=290


    Takao Yamada

  • Greetings,

    They look fine to me.
    I would advise going to our support page -> Support requests and submitting a ticket so that I can forward this issue to our DSC expert. Explain everything that we have already discussed, upload any images you have shared, and if possible share the binary file you have tried to program. We will try to replicate the issue here and see if we get you back into working shape.


    Takao Yamada

    • Thank you for your help! I went ahead and created a request.

  • For anyone stumbling across this issue in the future, the problem was a lack of a reset delay.

    Under the 'Reset Signal Settings' in the Cyclone Image Creation Utility, I needed to check the box and set the value to 250ms for the option that reads "After Reset, delay ____ms before contacting target and enter programming mode."

    Once I did this and regenerated the SAP image, the Cyclone MAX was able to push it down successfully.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement