Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone Max flash programming_Error$00000007
erhan b. May 5, 2016 at 12:40 PM (12:40 hours)
Staff: Kevin M.

  • Hello I am using Cyclone Max now. my MCU is S9KEAZN8AVTG. It is reporting that the programmer is giving an ERROR 07 which means $0007: Error entering debug modeThis is happening on all boards. I provide VDD the other source. And also I connected the gnd cyclone max and source.I use standard SWD 20 pin.

    Could you please support us that issue asap. We use whole automotive project freescale and I need urgently help. Thank you in advance




    Comments

  • Erhan,

    Are you using the JTAG/SWD adapter? This is required if you are using SWD.

    Can you try connecting with JTAG?

    Best,

    Kevin

  • hello Kevin,

    I don't have jtag/swd adapter. So which is the clock pin

  • on the jtag mode

  • The clock pin is the same in JTAG and SWD mode.

  • I tryied but it is not working

  • Erhan,

    Did you end up purchasing the adapter?

    Best,

    Kevin

  • Dear Kevin,

    We solved the problem and now we are using the cyclone max programmer.

    Thank you for your support.

  • Hi mates,

    I have the same problem with the Kinetic Microcontroller KL25Z128VLK4. I am using Cyclone Max in order to programming it. Also I use the "Imagen Creation Utility Version 5.77.10.00" and I made an adapter on my own.
    However, when I try to program it in standalone mode my cyclone report Error$00000007.

    I do not have much experience and I need help.

    Thank you in advance.

  • Hi Ruben;

    I dont have adapter and I applyied swd mode.

    So ıf you don't use adapter you should try to short pin7 and pin13.

    Also on the power supply gnd and VCC should be connect to gnd and vcc of cyclone max.

    I hope I could help you.

  • Hi Erhan,

    Thank for your answer, I am using Pin1=VCC, PIN7=SWD, PIN9=SWC and PIN4=GND.
    If I short pin7 and pin13 I have the same result.

  • Did you connect power supply outout to cyclonemax VCC and GND?

  • Yes I did. 

    Could be possible the image which is loaded in Cyclone has a mistake because of shift Frequency or other configuration parameters?. But MCU alghoritm define them by default.
    On the other hand I am using a windows 10 OS.

  • Erhan,

    Can you try using progacmp_cyclone.exe first to verify connections?

    Make sure SWD is checked and your target is powered.

    Best,

    Kevin

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement