Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Programming Freescale AP32 with Cyclone Pro
Brian B. Dec 4, 2015 at 05:04 PM (17:04 hours)
Staff: Takao Y.

  • I am trying to program a freescale AP32 micro with a cyclone pro.  I am using Algorithm HC08\908_AP32_Highspeed.08P and always getting a $00000005 and $00000007.  I am connecting the target to the 16pin ribbon connector with the cyclone providing the power.  

    I am routing from the cyclone
    Pin 15 to +5V
    Pin 2 to GND
    Pin 4 to Reset
    Pin 6 to Interrupt
    Pin 13 to OSC

    I am leaving pins PA0, PB0, and PB1 not connected. I have the jumpers on the cyclone so that internal power is routed to MON08 port and have confirmed power is getting to the micro when trying to program.




    Comments

  • Greetings,

    Try the non-highspeed version of the algorithm and see if things improve.

    Another thing you should try is using the PROG08SZ software found in your Cyclone pro software package. This will help you in debugging why you get this error.


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

  • I have sent the programmer and Control with target micro to Freescale as I was still not able to program.  I have confirmed the AP32 micro is getting power, but still cannot connect.

  • Greetings,

    Any more news about this? Not sure why you sent your items to Freescale. They are probably as confused as you are.


    Takao Yamada

  • Freescale was able to get the control board with the AP micro to program.  They found a connection issue and confirmed that the .S19 exceeded the 32k, so they had to use the 64k algorithm.  

    Thanks for your help, should be good to go now.

    -Brian

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement