Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cyclone MAX and JTAG not working after firmware update.
Noah Z. Sep 30, 2015 at 04:13 PM (16:13 hours)
Staff: Gerardo R.

  • We have 3 Cyclone Max programmers(A,B, and C) and are using JTAG to program. 

    We were having trouble programming a few PCB's and realized that "A" was Firmware v7.85, "B" and C" were Firmware v7.89. Using the exact same image, cables, and pcb, "A" would work with JTAG but "B" and "C" would not (Error $00000007).

    Last week "A" got updated to v7.89 and we can no longer program with JTAG (Error $00000007). Just downloaded the Cyclone MAX Single File Installation, and upgraded "A" to v7.90 and still no JTAG.


    Any ideas how to get JTAG working again?


    (side note, SWD works fine on all units no matter what.)




    Comments

  • Hello, what is the exact target part number and programming routine you are using to program? I'd like to try this out in the office.

    • -ARP file: freescale_mk61fn1m0_1x32x256k_pflash.arp 
      -Communication Mode Settings: ARM CORTEX 10 PIN MINI

      Is this the information you as asking for?

  • I have sent you instructions on how to downgrade your firmware and I'll look into if there was a regression in the newly released firmwares.

    • I can see the download link on top after I log in but if I click it I get:

      "Server Error
      404 - File or directory not found.
      The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable."

      Ill try again in an hour...

      • Same thing, server error, 404- file or directory not found...

        Can you use my email?

        thanks for working on this.

        • That worked, downgrading to 7.85 now lets us program JTAG again, thanks.

          • I need to downgrade the firmware for a Cyclone Max. Can you email me the instructions?

            Bobby Cannaday --- bcannaday@alpha.com

            • What version of the firmware would you like to downgrade to and why?

              • Hy, I need to downgrade the firmware of a cyclone max. The actual firmware is V7.92-6.2. With this firmware, it is not possible to program with JTAG (error $00000007). We use an other cyclone max with the firmware version  V7.70-6.0. There is no problem with this version. So can you email me how to downgrade the firmware to V7.70-6.0 for the Cyclone Max ?

  • Hello, if you would like to try the latest 7.91. One of the engineers told me they fixed an issue with JTAG.

    • standing by for 7.91...

  • Sorry, the latest firmware is always included in the Cyclone MAX single file installer on our support page.

    http://www.pemicro.com/downloads/download_file.cfm?download_id=290

    • Looks good, build 7.91 on cyclone max, JTAG and SWD is working just as it did in build 7.85. Thanks!

  • I have same problem here, after upgrading to v7.94-6.2. v7.91 have been working fine for my setup.

    Please help me with procedure to downgrade back to v.7.91. Its wasting so much time, i need help quickly.
    Thanks

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement