Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
$0007 error when programming with Cyclone Max
Whitney C. Jul 2, 2015 at 01:58 PM (13:58 hours)
Staff: Takao Y.

  • Hi,

    We are receiving error $0007 when attempting to program the SPC5674F using an image stored on the Cyclone Max programmer.We are using the Freescale_MPC5674F_1x32x1024k.pcp programming algorithm. We have used the same setup in the past to program this board. The Cyclone Max says it is version V7.85-6.2. My image creation utility is 5.21.00.00. We recently had to update the software in order to program a different microprocessor.

    While troubleshooting, I got the .SAP image file from our ICT group that is being used to program production boards, but that also produced the $0007 error code.

    In other threads it was suggested to use the PROG program to debug. I tried to use the PROGPPCNEXUS program, but was unable to connect. Any suggestions are appreciated.

    Thank you for the help.




    Comments

  • Greetings,

    Error $0007 indicates cannot enter background mode. Therefore the P&E hardware interface can detect your chip, but it was not able to enter debug mode before it attempts to load the algorithm.

    PROG is a great place to start and I want you to try lowering the debug shift frequency when you start the software. Use trial and error and slow down the frequency until you tried all options.

    Some questions:
    1) Are you using any custom hardware like custom ribbon cables, adapters, reset driver, or other unique setup? If you have a reset driver, try adding a reset delay within the connection manager when you first start up PROG.

    2) Do you censor the chip? If so, you may need to enter the password to uncensor the chip. Within the connection manager of PROG, use the advanced options to enter your password.


    Takao Yamada

  • Greetings,

    Any update on this?


    Takao Yamada

  • Hi Takao,

    We resolved our issue. Thank you for the support.

    Whitney

  • I am using a Cyclone Pro to program a MC9S08 in stand-alone mode.  Pro firmware is rev 8.62-1.6.  I am using the 6 pin BDM connector (4 wires) to connect to target.  I am getting Error $0007 when I attempt to program the MC9S08.

    • Greetings,

      Error $0007 for S08 is very different from PowerPC Nexus, which is what this original thread was about. Could you please create a new forum thread? Also please check the other forum topics?

      Error $0007 is very popular and usually due to communication between the P&E hardware and the target board. Please check your connections, power, and settings you have used in the image creation utility. Also try using the PROG software found in your cyclone pro software package to debug the problem.


      Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement