Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
$00003003 error when programming on Cyclone ARM
Brian B. May 28, 2015 at 02:51 PM (14:51 hours)
Staff: Kevin M.

  • I am trying to program an ST Micro STM32F101RCT6 LQF 256k micro.  I have been using the cyclone for ST Micro without issues.  I recently purchased a Cyclone for ARM devices and am getting an $00003003 error about 50% of the time when programming, the other times it programs without issue.  

    On the ST Micro cyclone I am using an ST_STM32F101RC_1x16x128k.arp starting at 08000000. For the Cyclone ARM I am using the ST_STM32F101RC_1x32x64k.arp algorithm.




    Comments

  • Brian,

    I believe you may be talking to the part too fast.

    In the image creation utility, what debug shift frequency are you using? Try something lower, such as number 10 Shift Frequency 2.00 MHz.

    Let me know if this resolves your issue.

    Best,

    Kevin

  • Kevin,

    I tried the shift frequency at 2MHz and saw no change. The STmicro cyclone is able to run at 10MHz without issue. Can I use the algorithm for the STmicro cyclone on the Arm Cyclone?

  • Kevin,

    I just tried the STmicro algorithm ST_STM32F101RC_1x16x128k.arp starting at 08000000 and have been able to get 15 programs in a row without issue. I was failing on verifying the checksum if I did program on the ST_STM32F101RC_1x32x64k.arp algorithm.

    Thanks for your help, should be good to go.

    -Brian

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement