Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Cannot program correctly
Ainara S. Jul 6, 2017 at 03:36 AM (03:36 hours)
Staff: Johnny N.

  • Hi all,

    I have multiple devices (908AZ60) and cannot program properly any of them, they used to work so the configuration and hw should be ok.

    PROG08SZ v2.16
    Programming algorithm "908_az60a.08P" v1.20

    I contact the device, with "ignore security" selected, I also get successful reset flags (powered down below 0.1v, etc), and successful loading of programming algorithms. Erase Module, Upload and Verify command are also working.

    But when I try to program the device I get this:

    "Checking range of S records. Checked
    Programming and Verifying Address $0E00. Error writing data black to part. Do I reset"

    I do a reset (or clear and reset) but I get always the same result.

    I am quite new on Project but I know the S19 File I am using is working on other devíces with the same configuration. There is something I do not understand about the file. There is a kind of index "S123" before the address. When I upload the module from device the index is "S113", what does ít mean?

    On the other hand I am able to write a Byte (Option Program Bytes) in the address $0E00 (or any other address) so somehow the decive is writable.

    Any advice would be appreciated.

    Thanks!




    Comments

  • Ainara,

    Which PEmicro hardware programmer are you using?

    Regards,
    Johnny

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement