Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
CodeWarrior 10.6.4 for Coldfire and tower 52259 OSBDM
Mike E. Dec 17, 2015 at 08:48 AM (08:48 hours)
Staff: Takao Y.

  • Hoping this is a simple issue.  I have CW 10.6.4 and seems to be up-to-date.
    Running on Win7 64bit. I have tower 52259 and trying to use built in OSBDM and debugger tells me I have old firmware. I know it has like 31.21. I have 2 PCs that are saying same thing and one (home PC) that is working with similar setup. Can't seem to find the difference. on the 2 PCs when I install bootloader jumper windows can't install driver or doesn't have driver. Not sure. Can someone help me.

    Thanks in advance,




    Comments

  • Greetings,

    When you put the bootloader jumper, did you make sure to disconnect and reconnect the mini-USB cable? When you do, you should see that Windows is trying to install new drivers if it has not done so yet. If it fails, then you will need to update to our latest drivers.

    First, uninstall any P&E drivers you may already have. This can be done in control panel -> add/remove software. If it does not show up there, then go to device manager and while the OSBDM is connected you should see Jungo -> WinDriver show up. Right click it and uninstall.

    The latest drivers are here:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=53

    Then try again. You should only need to update the firmware once. If you home PC does not tell you to firmware update, then it does not have the latest files. You may want to try at home the firmware updater utility to see if you can get it updated:
    http://www.pemicro.com/downloads/download_file.cfm?download_id=348


    Takao Yamada

  • When trying to use as debugger should there be something else under Jungo.  I think the home PC has something else under that.  I have a multi link universal as well at home. Maybe that entry is for ML.  I followed your  instruction and still CW will not connect.  Yes, I disconnected cable from board when install jumper.  And when I do that 'unknown device'
    When setup as debugger I get entry under LibUSB-Win32 and one under ports.

    What should latest firmware be. I have programmed 31.21 I believe with multilink. What tells CW which firmware should be use. There used to be PE drivers under CW installation and now they are gone. probably when I uninstall drivers. I was able to update firmware at home using bootloader and your firmware updater. I think something is out of date on these 2 PCs.

  • Greetings,

    If you have a multilink, then that would show up under Jungo as well as "USB Multilink 2.0".

    Lastest firmware for OSBDM should be 31.26. The multilink cannot program the firmware of the OSBDM. It can program the firmware of your chip (MCF52259). If you actually installed the drivers correctly, you should see Jungo -> WinDriver again. Please disconnect all P&E hardware and try installing the drivers again.


    Takao Yamada

  • I am getting something wierd.  Initially CW say's firmware is old but if I 'retry' one or 2 time it might go.  There is a screen that comes for a short period and is red and sometimes with nothing showing. Sometimes it shows 31.21.

    From the first dialog box showing firmware out of date, I click 'cancel' and then the red box comes up and show 31.21 for about 2 sec and then I get 'Warning' box. about retrying again. If I say no then 'P&E Connection Assistant' dialog shows up. I click 'retry' and sometimes it works.

    Connection must be unreliable. I tried several cables.

  • Actually I think the ML will update firmware using your recovery tool.
    I could be wrong. Either way last night I did use your firmware updater successfully and put in 31.21

    How do I get 31.26 firmware.

  • Greetings,

    Just clicking cancel will only bypass the issue and not resolve the problem.
    Your connection is fine.

    Are you using any kind of virtual machine? I know sometimes this causes more problems especially with drivers.

    When you connect the bootloader jumper and reconnect the mini-USB, check your device manager. Is there anything in "!" symbol? This indicates some driver issue.


    Takao Yamada

  • No VM.  When installing bootloader jumper I get 'Unknown device' under USB controllers. That is the only time I have what appears to be driver issue.

  • Greetings,

    On very rare occasions, some computers have difficulty getting the bootloader driver to work. Are these 2 machines identical? Do you happen to have another computer that is different? Try using the firmware updater utility I have mentioned on a different computer and see if you are able to update it to version 31.26.

    Updating the firmware using the multilink is only used to recover the firmware to an older and stable version. This option is not found in the 31.26 firmwares.


    Takao Yamada

  • I am curious how to get 31.26

    2 PCs now that work. My home PC and laptop. I definitely see the bootloader port.

    I use the Firmware Information Utility and it reports 31.21 and that is on the problem PCs.

    There is a virtual serial port (CDC) under 'ports' and a debug port under LibUSB-Win32

    Which one would be at fault

  • Greetings,

    I do not understand how you are still on 31.21 if you have bootloader showing up. In Codewarrior, when it asks you to switch to bootloader, if you click okay it should then firmware update while in bootloader mode. After firmware updating, it will ask you to switch out of bootloader and you will successfully have firmare 31.26.

    Right now, just focus on using the 2 computers that work and just firmware update to 31.26. Just do it once and you never ever have to be in bootloader mode again.


    Takao Yamada

  • I have and it never gives me an option for 31.26.  CW works with 31.21 and never complains about version.  The only time I can update is by running your updater program and then can only select 31.21 file.

    I am going to uninstall CW. and reinstall.

    But would CW have anything to do with drivers. When using bootloader mode I get 'unable to recognize device'

  • Greetings,

    Installing Codewarrior should install our drivers, but I highly suggest just installing the drivers manually.

    I have sent you a zip file of new firmwares. Dump these into the firmware updater utility for OSBDM and see if you can update to 31.26.


    Takao Yamada

  • Well, I have successfully installed .26 and believe it or not the laptop took off and entered debug.  But, bootloader still failed to enumerate. I will try office desktop later next week.  Thank you for your time troubleshooting this.
    Hopefully this gets me for a while.

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement