Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
Can an older automation DLL work with the cyclone universal?
Jason F. Dec 1, 2015 at 10:21 AM (10:21 hours)
Staff: Johnny N.

  • I have currently been using the CYCLONEPROMAX_PROGRAMMING.dll released in 2006.  We just recently got a cyclone universal, and I am able to connect to it via ethernet, but I am unable to upload SAP files to the cyclone.  it gives me error 1E.

    The functions that do not appear to be working are:
    compare_image_with_file
    update_image_with_file
    reset_cyclonepromax

    The update and compare are necessary for what we do, as we change programs constantly in production.




    Comments

    • Hi Jason,

      Old Automated Control DLLs may not be fully compatible with the new Cyclone Universals. The APIs for the two programmers are slightly different. We are trying to update the DLL as soon as possible but it isn't ready at this point. How soon do you need it?

      Regards,
      Johnny
      P&E

      • We don't need it right away, will the old automation dlls work with the ARM cyclone?

        When the dll is updated, how would I be able to get it?

        Thanks,
        Jason

        • Jason,

          The DLLs will work with the Cyclone for ARM. I can put you in our email notification list for the Automated Control Package if that is okay with you.

          Regards,
          Johnny
          P&E

          • That will be great, thanks!

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement