Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
eclipse plugin
Carlos C. Apr 23, 2015 at 04:31 PM (16:31 hours)
Staff: Takao Y.

  • where can I find

    GNU ARM PEMicro Interface Debugging Support   1.1.8.201411191655

    I've just upgraded to

    GNU ARM PEMicro Interface Debugging Support   2.0.8.201504092111   

    but it doesn't work.

    Thank you.




    Comments

  • Greetings,

    What is not working about the latest plugin? We do not allow downloads of lower versions. I can do my best to help you get your setup working again.


    Takao Yamada

    • Takao,

      Finally I could make it work. You have to re-do all debug configurations in your workspace and then everything works.

      I noticed that the first time PE Multilink is accessed its firmware is updated. Perhaps that is the reason you decided that the Eclipse upgrade procedure delete the older versions of the plugin. That has the effect of disabling the revert option in Eclipse.

      You should try to find a better way to communicate how to proceeed after upgrading.

      Regards,
      Carlos

  • Greetings,

    What version of KDS were you using?

    Version 2.0 or higher is backwards compatible so you should not need to regenerate the debug configurations to get it working. If you had KDS 1.0 or 1.1, then yes you do have to regenerate the debug configurations. We have fixed that since.

    Glad to know that you got your setup working again.


    Takao Yamada

    • I am using KDS 2.0

      When upgrading from GNU ARM PEMicro Interface Debugging Support 1.1.8.201411191655 to GNU ARM PEMicro Interface Debugging Support 2.0.8.201504092111 last week, I had to regenerate all my debug configurations.

      As I mentioned, once I did that, my Multilink firmware was upgraded too y then everything worked.

  • Greetings,

    There is a similar bug report about this issue and I have brought it up with our developers to look into.

    Thank you for bringing this issue up with us and I hope future upgrades to our plugin will not have this problem.


    Takao Yamada

Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement