Cart New Account Login

HomeAbout usProductsSupportForumsBlogCustomer Service

search inside this forum
PROGCFZ and USB-ML-CFE losing comm with MCF5272 during upload
Jim T. migrated on Dec 31, 2013 at 11:00 AM
No staff assigned yet

  • Hello,

    I am using PROGCFZ v1.88.00.00 and algorithm file SST_39VF040_1x8x512k.CFP with USB-ML-CFE Rev. C to connect to the BDM on an MCF5272 with SST 39VF040 flash memory.

    When I run 'SC Show Module CRC' it works consistently and reports the same CRC value each time.

    But when I run 'UM Upload module', the results vary. Sometimes the upload completes, but a diff comparison of repeated uploads indicates a few byte mismatches in the uploaded S-Records.

    Other times (often), the upload suddenly slows considerably. I press ESC to end the upload, and when I then try 'SC Show Module CRC', I get the response:

    Error communicating to target processor - try a RESET.

    So it appears communications with the target are lost during the upload.

    In the Connection Manager dialog, I have tried a wide range of values for BDM Debug Shift Freq, and have manually set a range of values for MCU Internal Bus frequency.

    Changing these speed settings seems to improve the 'UM Upload module' results somewhat, resulting in less errors, but never no errors.

    What should I try?

    Is PROGCFZ v1.88.00.00 with USB-ML-CFE Rev. C a known good combination?

    Thanks.

    Jim





    Comments

  • QUOTE (jthomas @ Oct 13 2010, 05:29 PM) [legacy comment]
    Hello,

    I am using PROGCFZ v1.88.00.00 and algorithm file SST_39VF040_1x8x512k.CFP with USB-ML-CFE Rev. C to connect to the BDM on an MCF5272 with SST 39VF040 flash memory.

    When I run 'SC Show Module CRC' it works consistently and reports the same CRC value each time.

    But when I run 'UM Upload module', the results vary. Sometimes the upload completes, but a diff comparison of repeated uploads indicates a few byte mismatches in the uploaded S-Records.

    Other times (often), the upload suddenly slows considerably. I press ESC to end the upload, and when I then try 'SC Show Module CRC', I get the response:

    Error communicating to target processor - try a RESET.

    So it appears communications with the target are lost during the upload.

    In the Connection Manager dialog, I have tried a wide range of values for BDM Debug Shift Freq, and have manually set a range of values for MCU Internal Bus frequency.

    Changing these speed settings seems to improve the 'UM Upload module' results somewhat, resulting in less errors, but never no errors.

    What should I try?

    Is PROGCFZ v1.88.00.00 with USB-ML-CFE Rev. C a known good combination?

    Thanks.

    Jim


    I replaced the USB-ML-CFE Rev. C with Rev. D, and now 'UM Upload module' runs much more quickly and produces exact matching S-Records across every run. There must have been some Rev C versus Rev D issue responsible for the prior marginal results.

    Thanks.

    Jim


Add comment


   Want to comment? Please login or create a new PEMicro account.







© 2017 P&E Microcomputer Systems Inc.
Website Terms of Use and Sales Agreement